Commit eec6f284 authored by Owen Arnold's avatar Owen Arnold
Browse files

Default to version 0.1.0 for now

We still have ongoing issues with astropy requireing a VC++ compiler,
and that is unacceptable.
parent 5f8ba6b3
...@@ -37,7 +37,7 @@ def extract_upload_url(python, required_version=None): ...@@ -37,7 +37,7 @@ def extract_upload_url(python, required_version=None):
gl = gitlab.Gitlab('https://git.esss.dk') gl = gitlab.Gitlab('https://git.esss.dk')
project = gl.projects.list(search='wfm_stitching')[0] project = gl.projects.list(search='wfm_stitching')[0]
if required_version: if required_version:
tag = project.tags.get('v{0}'.format(required_version)) tag = project.tags.get(required_version)
else: else:
# Get the latest tag # Get the latest tag
tag = project.tags.list(order_by='updated', sort='desc')[0] tag = project.tags.list(order_by='updated', sort='desc')[0]
...@@ -55,14 +55,14 @@ def do_wfm_stitching_install(python, required_version): ...@@ -55,14 +55,14 @@ def do_wfm_stitching_install(python, required_version):
def do_wfm_stitching_uninstall(python): def do_wfm_stitching_uninstall(python):
"""Convenience function to allow the removal of the wfm-stitching package""" """Convenience function to allow the removal of the wfm-stitching package"""
subprocess.check_call([python, '-m', 'pip', 'uninstall', '-y', 'wfm-stitching']) subprocess.check_call([python, '-m', 'pip', 'uninstall', '-y', 'wfm_stitching'])
subprocess.check_call([python, '-m', 'pip', 'uninstall', '-y', 'python-gitlab']) subprocess.check_call([python, '-m', 'pip', 'uninstall', '-y', 'python-gitlab'])
if __name__ == "__main__": if __name__ == "__main__":
parser = ArgumentParser(description='Install WFM package http://git.esss.dk/wedel/wfm_sitching') parser = ArgumentParser(description='Install WFM package http://git.esss.dk/wedel/wfm_sitching')
parser.add_argument('-v', '--version', default=None, parser.add_argument('-v', '--version', default='v0.1.0',
help='optionally specify the version you wish to use i.e. v0.1.2.' help='Specify the version you wish to use i.e. v0.1.2.'
'Defaults to latest version. Version must match git tag version.') 'Defaults to version v0.1.0. Version must match git tag version.')
parser.add_argument('-u', '--uninstall', action='store_true', default=False, help='uninstall any existing wfm-stitching package') parser.add_argument('-u', '--uninstall', action='store_true', default=False, help='uninstall any existing wfm-stitching package')
args = parser.parse_args() args = parser.parse_args()
interpreter = os.path.join(os.path.dirname(sys.executable), 'python') interpreter = os.path.join(os.path.dirname(sys.executable), 'python')
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment